summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndoni Morales Alastruey <ylatuya@gmail.com>2021-09-30 13:01:26 +0200
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-04-05 08:28:50 +0000
commitf89dff303a1e06b91563d878607b5fb3c9e0cb04 (patch)
treee6624d1d2947608138b13ccdc8d3765ae97cd820 /meson.build
parent8537433f24a04423f1b77f190badfc16169add6d (diff)
downloadgstreamer-f89dff303a1e06b91563d878607b5fb3c9e0cb04.tar.gz
gstreamer-sharp: ensure a consitent code format
Use EditorConfig and dotnet-format to ensure a consistent code style. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/983>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0543316e11..b1b906acd6 100644
--- a/meson.build
+++ b/meson.build
@@ -450,6 +450,19 @@ if orc_subproject.found() and orc_update_targets.length() > 0
alias_target('update-orc-dist', orc_update_targets)
endif
+dotnet_format = find_program('dotnet-format', required: false)
+if dotnet_format.found()
+ run_target('csharp_format_check',
+ command: [join_paths(meson.current_source_dir(), 'scripts', 'format-chsharp'),
+ '--check'
+ ],
+ )
+ run_target('csharp_format_apply',
+ command: [join_paths(meson.current_source_dir(), 'scripts', 'format-chsharp'),
+ ],
+ )
+endif
+
summary({
'gstreamer-full': building_full,
}, section: 'Build options', bool_yn: true, list_sep: ' ')