summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha@centricular.com>2021-09-29 01:30:46 +0900
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2021-11-19 22:13:10 +0000
commitedbd307df95bda055b19aee3d45b7f914e7100d9 (patch)
treee38cc991a4e3eeeca7cfb8c0c3b17be4ebe565e5 /meson.build
parentc2bffe22f36a917c2df341f01066095310be6d50 (diff)
downloadgstreamer-edbd307df95bda055b19aee3d45b7f914e7100d9.tar.gz
meson: Disable symlink to gst modules
Symlink to directory usually makes IDE be confused, and also any git command to the symlink would not work. Disable the symlink since we don't see any advantage of the use case at the moment. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/949>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index af96740425..c1f2887651 100644
--- a/meson.build
+++ b/meson.build
@@ -148,10 +148,6 @@ foreach sp : subprojects
orc_update_targets += subproj.get_variable('orc_update_targets', [])
subprojects_names += [project_name]
- cmdres = run_command(python3, '-c', symlink.format(project_name, meson.current_source_dir()))
- if cmdres.returncode() == 0
- message('Created symlink to ' + project_name)
- endif
if not meson.is_cross_build() and build_infos.get('build-hotdoc', false)
if plugins.length() > 0