summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2020-07-04 15:00:35 +0100
committerTim-Philipp Müller <tim@centricular.com>2020-07-04 15:01:08 +0100
commitebf79cf723813e902c3f13da882a0f95a4fa8d53 (patch)
tree6de38ced4415e8395f89612b4b47e1a9395dbd38 /meson.build
parent45a09d4a81e13f10c643e8e14018479130df72c6 (diff)
downloadgstreamer-ebf79cf723813e902c3f13da882a0f95a4fa8d53.tar.gz
Add update-orc-dist target
Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-build/-/merge_requests/168>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ff397bfc02..dd35b4fdf9 100644
--- a/meson.build
+++ b/meson.build
@@ -87,10 +87,11 @@ if build_system == 'windows'
subproject('win-nasm')
endif
-subproject('orc', required: get_option('orc'))
+orc_subproject = subproject('orc', required: get_option('orc'))
subprojects_names = []
plugins_doc_caches = []
+orc_update_targets = []
all_plugins = []
foreach sp : subprojects
project_name = sp[0]
@@ -115,6 +116,8 @@ foreach sp : subprojects
endif
all_plugins += plugins
+ orc_update_targets += subproj.get_variable('orc_update_targets', [])
+
subprojects_names += [project_name]
cmdres = run_command(python3, '-c', symlink.format(project_name, meson.current_source_dir()))
if cmdres.returncode() == 0
@@ -308,3 +311,7 @@ update = find_program('git-update')
run_target('git-update', command : [update])
run_target('update', command : [update,
'--builddir=@0@'.format(meson.current_build_dir())])
+
+if orc_subproject.found()
+ alias_target('update-orc-dist', orc_update_targets)
+endif