summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStéphane Cerveau <scerveau@igalia.com>2022-12-05 08:50:43 +0000
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-12-05 13:15:50 +0000
commitce50cb7413579f15f2dfef986c68f0bcfee9570e (patch)
tree4aa5f593e97efdf29a3ea6fd250e704140dede0b /meson.build
parent63b598b40955b49e30ce0be5fc48f641884410e9 (diff)
downloadgstreamer-ce50cb7413579f15f2dfef986c68f0bcfee9570e.tar.gz
gstreamer-full: use the basename of plugin_path to avoid the ':' detection
The absolute path on windows contains ':' which prevents gstinitstaticplugins.py to work properly. Use the basename whic is good enough for the script to make the list of plugins Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3526>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e8ee12722a..e925ec907a 100644
--- a/meson.build
+++ b/meson.build
@@ -271,7 +271,7 @@ foreach plugin: all_plugins
plugin_path = plugin.get_variable('full_path')
all_plugins_paths += plugin_path
all_plugins_dirs += fs.parent(plugin_path)
- plugins_names += plugin_path
+ plugins_names += fs.name(plugin_path)
endforeach
# Work around meson bug: https://github.com/mesonbuild/meson/pull/6770