summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2021-12-12 13:20:55 +0000
committerThibault Saunier <tsaunier@igalia.com>2022-01-03 16:27:04 -0300
commitccf64e369e88f307c68879434f8e6c940aab3cb3 (patch)
tree87bb7da2a145bd064f425d93de1154f50f3688dd /meson.build
parentb0370cdf00371dc91e03a3b661cdc838e507949c (diff)
downloadgstreamer-ccf64e369e88f307c68879434f8e6c940aab3cb3.tar.gz
meson: Allow using GStreamer plugins from custom_subprojects
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1490>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 5234aaf063..d1af0bc8fc 100644
--- a/meson.build
+++ b/meson.build
@@ -114,6 +114,14 @@ endif
orc_subproject = subproject('orc', required: get_option('orc'))
+foreach custom_subproj: get_option('custom_subprojects').split(',')
+ if custom_subproj != ''
+ message ('Adding custom subproject ' + custom_subproj)
+ subprojects += [[custom_subproj, {'match_gst_version': false}]]
+ endif
+endforeach
+
+
subprojects_names = []
plugins_doc_caches = []
orc_update_targets = []
@@ -369,14 +377,6 @@ if get_option('default_library') == 'static'
meson.override_dependency('gstreamer-full-1.0', gst_full_dep)
endif
-foreach custom_subproj: get_option('custom_subprojects').split(',')
- if custom_subproj != ''
- message ('Adding custom subproject ' + custom_subproj)
- subproject(custom_subproj)
- subprojects_names += [custom_subproj]
- endif
-endforeach
-
message('Building subprojects: ' + ', '.join(subprojects_names))
setenv = find_program('gst-env.py')