summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2023-04-14 13:13:24 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2023-04-28 15:21:10 +0530
commitbeb21f925493f02d3f071661298ad8b647c9f8df (patch)
tree5c7023e472704587e613ce1c54cb620701663f84 /meson.build
parent3a09e700e6ebc46843dca79a699c94bacaf0df71 (diff)
downloadgstreamer-beb21f925493f02d3f071661298ad8b647c9f8df.tar.gz
meson: Add a new option to control the source for build-tools
Similar to orc, allow distros to force bison, flex, nasm, etc, to be provided by the system. Needed by the Homebrew folks: https://github.com/Homebrew/homebrew-core/pull/125996#discussion_r1166410216 Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/4428>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 2b140c8692..39daf5ee86 100644
--- a/meson.build
+++ b/meson.build
@@ -113,11 +113,13 @@ subprojects = [
['gst-plugins-rs', { 'option': get_option('rs'), 'build-hotdoc': true, 'match_gst_version': false}],
]
-if build_system == 'windows'
- subproject('win-flex-bison-binaries')
- subproject('win-nasm')
-elif build_system == 'darwin'
- subproject('macos-bison-binary')
+if get_option('build-tools-source') == 'subproject'
+ if build_system == 'windows'
+ subproject('win-flex-bison-binaries')
+ subproject('win-nasm')
+ elif build_system == 'darwin'
+ subproject('macos-bison-binary')
+ endif
endif
orc_option = get_option('orc')