summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2022-09-01 11:51:48 -0400
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-09-01 21:17:35 +0000
commitbc9c1e39561450d3e35ede27e2eacb873c659910 (patch)
treed651dbd49b0a7ba03b3e64495eab4cada15798d4 /meson.build
parentc971a6d71f7c4267f40ff4e78be5a55ad603aa2c (diff)
downloadgstreamer-bc9c1e39561450d3e35ede27e2eacb873c659910.tar.gz
meson: Namespace the plugins_doc_dep/libraries variables
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/2970>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 7cb37f9924..ae1141645e 100644
--- a/meson.build
+++ b/meson.build
@@ -184,7 +184,7 @@ foreach sp : subprojects
endforeach
endif
- all_libraries += subproj.get_variable('libraries', [])
+ all_libraries += subproj.get_variable('gst_libraries', [])
if not get_option('tools').disabled()
all_tools += subproj.get_variable('gst_tools', {})
endif
@@ -194,7 +194,7 @@ foreach sp : subprojects
subprojects_names += [project_name]
if not meson.is_cross_build() and build_infos.get('build-hotdoc', false)
- plugins_doc_caches += [subproj.get_variable('plugins_doc_dep', [])]
+ plugins_doc_caches += [subproj.get_variable('gst_plugins_doc_dep', [])]
if documented_projects != ''
documented_projects += ','
endif
@@ -210,7 +210,7 @@ if glib_dep.type_name() == 'internal'
default_options: ['gnutls=auto', 'openssl=auto'])
endif
-plugins_doc_dep = custom_target('plugins-doc-cache',
+gst_plugins_doc_dep = custom_target('plugins-doc-cache',
command: [python3, '-c', 'print("Built all doc caches")'],
input: plugins_doc_caches,
output: 'plugins_doc_caches',