summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2022-08-31 14:15:16 -0400
committerThibault Saunier <tsaunier@igalia.com>2023-04-22 09:32:32 -0400
commitb14e675a2786c31aa614ed23591fbed03d05a946 (patch)
tree734669cdb6c63a3fbe7ab27f796e044d47665094 /meson.build
parentd4a910649955ecbee2db1ced67eed748995f6d58 (diff)
downloadgstreamer-b14e675a2786c31aa614ed23591fbed03d05a946.tar.gz
gir: Checkout all .gir files and check that they are updated on the CI
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3010>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index abc46b6d3e..2b140c8692 100644
--- a/meson.build
+++ b/meson.build
@@ -225,6 +225,23 @@ gst_plugins_doc_dep = custom_target('plugins-doc-cache',
capture: true,
)
+gir_files = []
+gir_targets = []
+foreach pkgname_library : all_libraries
+ lib_def = pkgname_library[1]
+ foreach gir_target: lib_def.get('gir_targets', [])
+ gir_files += [gir_target[0].full_path()]
+ gir_targets += gir_target
+ endforeach
+endforeach
+
+custom_target('update_girs',
+ command: [find_program('scripts/update-girs.py'), meson.build_root()] + gir_files,
+ output: 'update_girs',
+ capture: true,
+ depends: gir_targets
+)
+
if meson.is_cross_build() or build_machine.system() == 'windows'
if get_option('doc').enabled()
error('Documentation enabled but building the doc while cross building or building on windows is not supported yet.')