summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2022-09-21 19:19:45 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2022-09-21 21:08:11 +0530
commita0e6278dba899f122d806994d47ee0e2c1741b34 (patch)
tree668e92d1045aa5acb7ba634f73368a1886afff00 /meson.build
parenta9144f5313ce8a9af2735209db88bbd6bb096ee1 (diff)
downloadgstreamer-a0e6278dba899f122d806994d47ee0e2c1741b34.tar.gz
meson: Use implicit builtin dirs in pkgconfig generation
Starting with Meson 0.62, meson automatically populates the variables list in the pkgconfig file if you reference builtin directories in the pkgconfig file (whether via a custom pkgconfig variable or elsewhere). We need this, because ${prefix}/libexec is a hard-coded value which is incorrect on, for example, Debian. Bump requirement to 0.62, and remove version compares that retained support for older Meson versions. Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1245 Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3061>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 1 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index 0df45b3e7d..47567e6e4b 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gstreamer-full', 'c',
version : '1.21.0.1',
- meson_version : '>= 0.60.0',
+ meson_version : '>= 0.62.0',
default_options : ['buildtype=debugoptimized',
# Needed due to https://github.com/mesonbuild/meson/issues/1889,
# but this can cause problems in the future. Remove it
@@ -33,21 +33,6 @@ endif
# Install gst-indent pre-commit hook
run_command(python3, '-c', 'import shutil; shutil.copy("scripts/git-hooks/multi-pre-commit.hook", ".git/hooks/pre-commit")', check: false)
-# Ensure that the user does not have Strawberry Perl in PATH, since it ships
-# with a pkg-config.bat and broken pkgconfig files for libffi and zlib. Will
-# cause a build error, such as in
-# https://gitlab.freedesktop.org/gstreamer/gst-build/-/issues/41
-ensure_no_strawberry_perl = '''
-import os
-assert(r'Strawberry\perl\bin' not in os.environ['PATH'])
-'''
-if build_system == 'windows' and meson.version().version_compare('<0.60.0')
- cmdres = run_command(python3, '-c', ensure_no_strawberry_perl, check: false)
- if cmdres.returncode() != 0
- error('You have Strawberry Perl in PATH which is known to cause build issues with Meson < 0.60.0. Please remove it from PATH, uninstall it, or upgrade Meson.')
- endif
-endif
-
# On macOS, you have to run "Install Certificates.command" otherwise Python
# doesn't have access to the latest SSL CA Certificates, and Meson will fail to
# download wrap files from websites that use, for example, Let's Encrypt.