summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2022-02-21 11:35:41 -0500
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-02-25 20:35:26 +0000
commit968a26e6f6073f518b1b61f22ce61f6d008037ae (patch)
tree1510f40ae2398085da8f09729a0fb33287ec6f8d /meson.build
parent3941eb7dbd694f7ae573e67172e7df514cbd5f2a (diff)
downloadgstreamer-968a26e6f6073f518b1b61f22ce61f6d008037ae.tar.gz
devenv: Prepend to GST_PLUGIN_PATH
Use may have their own GST_PLUGIN_PATH, or a custom user subproject could have their own plugins too. This is also what gst-env.py does. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1768>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 52c8aafaf1..53bdcf56f1 100644
--- a/meson.build
+++ b/meson.build
@@ -234,7 +234,7 @@ pathsep = host_machine.system() == 'windows' ? ';' : ':'
all_plugins_paths = pathsep.join(all_plugins_paths)
devenv = environment()
-devenv.set('GST_PLUGIN_PATH', all_plugins_dirs)
+devenv.prepend('GST_PLUGIN_PATH', all_plugins_dirs)
devenv.set('CURRENT_GST', meson.current_source_dir())
devenv.set('GST_VERSION', meson.project_version())
devenv.set('GST_ENV', 'gst-' + meson.project_version())