summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2021-10-18 15:47:00 +0100
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2021-10-20 11:20:44 +0000
commit8dfab0b08c86989e5c911db472b7677f60c1b978 (patch)
treeebcddbe9c915088d8b680e695b00468c6c16d965 /meson.build
parentf1bb2c76c6a8fff91ecde68f6553ce8e133f7521 (diff)
downloadgstreamer-8dfab0b08c86989e5c911db472b7677f60c1b978.tar.gz
meson: update for meson.build_root() and .build_source() deprecation
-> use meson.project_build_root() or .global_build_root() instead. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1183>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index af130e9ecf..f7f373a64d 100644
--- a/meson.build
+++ b/meson.build
@@ -384,9 +384,9 @@ endforeach
message('Building subprojects: ' + ', '.join(subprojects_names))
setenv = find_program('gst-env.py')
-devenv_cmd = [setenv, '--builddir=@0@'.format(meson.build_root()),
+devenv_cmd = [setenv, '--builddir=@0@'.format(meson.project_build_root()),
'--gstbuilddir=@0@'.format(meson.current_build_dir()),
- '--srcdir=@0@'.format(meson.source_root())]
+ '--srcdir=@0@'.format(meson.project_source_root())]
subdir('tests')
if meson.has_exe_wrapper() and build_machine.system() == 'linux' and host_machine.system() == 'windows'