summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2022-06-23 11:50:00 -0400
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-09-14 20:46:20 +0000
commit412362281fc28f64b39660764d7d5358d4bbe269 (patch)
treec77eed4dfa4d455500bda96d7fca8ebdd15ae8b4 /meson.build
parent124f93a05d0e9578c0c324b1dadffbc8519930b9 (diff)
downloadgstreamer-412362281fc28f64b39660764d7d5358d4bbe269.tar.gz
gst-full: Register GIO modules when glib-networking is a subproject
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/2653>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 13 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 69f7d9bf46..1da3ac6db8 100644
--- a/meson.build
+++ b/meson.build
@@ -205,10 +205,14 @@ foreach sp : subprojects
endforeach
# Check if we need to also build glib-networking for TLS modules
+giomodules = []
glib_dep = dependency('glib-2.0')
if glib_dep.type_name() == 'internal'
- subproject('glib-networking', required : get_option('tls'),
+ subp = subproject('glib-networking', required : get_option('tls'),
default_options: ['gnutls=auto', 'openssl=auto'])
+ if subp.found()
+ giomodules += subp.get_variable('giomodules', [])
+ endif
endif
gst_plugins_doc_dep = custom_target('plugins-doc-cache',
@@ -322,7 +326,8 @@ if building_full
'-e ' + get_option('gst-full-elements'),
'-t ' + get_option('gst-full-typefind-functions'),
'-d ' + get_option('gst-full-device-providers'),
- '-T ' + get_option('gst-full-dynamic-types')
+ '-T ' + get_option('gst-full-dynamic-types'),
+ '--giomodules', ';'.join(giomodules),
]
)
@@ -385,12 +390,17 @@ if building_full
endif
endif
+ giomodules_deps = []
+ foreach module : giomodules
+ giomodules_deps += dependency(module)
+ endforeach
+
# Build both shared and static library
gstfull = both_libraries('gstreamer-full-1.0',
init_static_plugins_c,
link_args: gstfull_link_args,
link_whole : exposed_libs,
- dependencies : [incdir_deps, glib_deps, all_plugins],
+ dependencies : [incdir_deps, glib_deps, all_plugins, giomodules_deps],
link_depends : link_deps,
install : true,
)