summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2022-03-18 13:43:00 +0530
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-03-18 22:49:16 +0000
commit2913ab9dbf79aac32c8c0e1e5294db0c919b82d2 (patch)
tree7c2408410ffe679a45d5e5dc95e4a87407b2b6c9 /meson.build
parent1cb127f16b040659c138ca14cc780227394ae8c7 (diff)
downloadgstreamer-2913ab9dbf79aac32c8c0e1e5294db0c919b82d2.tar.gz
meson: Fix warning about build_root() and source_root()
``` ../meson.build:384: WARNING: Project targeting '>= 0.60.0' but tried to use feature deprecated since '0.56.0': meson.build_root. use meson.project_build_root() or meson.global_build_root() instead. ../meson.build:385: WARNING: Project targeting '>= 0.60.0' but tried to use feature deprecated since '0.56.0': meson.source_root. use meson.project_source_root() or meson.global_source_root() instead. ... WARNING: Deprecated features used: * 0.56.0: {'meson.source_root', 'meson.build_root'} ``` Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1977>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ace91f107e..034aa9437f 100644
--- a/meson.build
+++ b/meson.build
@@ -381,8 +381,8 @@ message('Building subprojects: ' + ', '.join(subprojects_names))
setenv = find_program('gst-env.py')
-devenv_cmd = [setenv, '--builddir=@0@'.format(meson.build_root()),
- '--srcdir=@0@'.format(meson.source_root())]
+devenv_cmd = [setenv, '--builddir=@0@'.format(meson.global_build_root()),
+ '--srcdir=@0@'.format(meson.global_source_root())]
subdir('tests')
if meson.can_run_host_binaries() and build_machine.system() == 'linux' and host_machine.system() == 'windows'