summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-10-28 10:09:21 -0400
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2021-10-31 20:07:39 +0000
commit1ec04817eb0af92f53bf035033876d79117aeff2 (patch)
tree135f1184cfa98931f23c4d32023f7c17824d605c /meson.build
parent577cdcafe09f82bda9d36dadfd302e4ed1b4b251 (diff)
downloadgstreamer-1ec04817eb0af92f53bf035033876d79117aeff2.tar.gz
Allow Strawberry Perl on Windows with Meson >= 0.60.0
Meson now explicitly blacklists pkg-config.bat from Strawberry Perl and thus building GStreamer on Windows has been fixed. This allows for instance to build GStreamer on GitHub Action Windows runners that have Strawberry Perl by default. It is also useful when needing to build OpenSSL on the same Windows machine because it requires Perl. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1263>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 78dd640d68..10ad7cd55e 100644
--- a/meson.build
+++ b/meson.build
@@ -40,10 +40,10 @@ ensure_no_strawberry_perl = '''
import os
assert(r'Strawberry\perl\bin' not in os.environ['PATH'])
'''
-if build_system == 'windows'
+if build_system == 'windows' and meson.version().version_compare('<0.60.0')
cmdres = run_command(python3, '-c', ensure_no_strawberry_perl)
if cmdres.returncode() != 0
- error('You have Strawberry Perl in PATH which is known to cause build issues with gst-build. Please remove it from PATH or uninstall it.')
+ error('You have Strawberry Perl in PATH which is known to cause build issues with Meson < 0.60.0. Please remove it from PATH, uninstall it, or upgrade Meson.')
endif
endif