summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-02-21 10:20:15 -0500
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2021-10-19 16:18:43 +0000
commit14115b714fe96049137d065e649d5945d07c768a (patch)
tree884ea20265fb3240e981d677bb1bd4b85e55ce81 /meson.build
parent7cb2dff8307b9579c9e64fac7054185c82581f1c (diff)
downloadgstreamer-14115b714fe96049137d065e649d5945d07c768a.tar.gz
Add initial meson devenv support
There is still a few things missing compared to gst-env.py, but it is functional. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1162>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 12f02c9f5e..af130e9ecf 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,7 @@ gst_version = '>= @0@'.format(meson.project_version())
build_system = build_machine.system()
cc = meson.get_compiler('c')
+fs = import('fs')
gnome = import('gnome')
pkgconfig = import('pkgconfig')
python3 = import('python').find_installation()
@@ -219,13 +220,24 @@ if documented_projects != ''
endif
all_plugins_paths = []
+all_plugins_dirs = []
foreach plugin: all_plugins
all_plugins_paths += plugin.full_path()
+ all_plugins_dirs += fs.parent(plugin.full_path())
endforeach
# Work around meson bug: https://github.com/mesonbuild/meson/pull/6770
pathsep = host_machine.system() == 'windows' ? ';' : ':'
all_plugins_paths = pathsep.join(all_plugins_paths)
+devenv = environment()
+devenv.set('GST_PLUGIN_PATH', all_plugins_dirs)
+devenv.set('CURRENT_GST', meson.current_source_dir())
+devenv.set('GST_VERSION', meson.project_version())
+devenv.set('GST_ENV', 'gst-' + meson.project_version())
+devenv.set('GST_REGISTRY', meson.current_build_dir() / 'registry.dat')
+devenv.set('GST_PLUGIN_SYSTEM_PATH', '')
+meson.add_devenv(devenv)
+
generate_plugins_paths = find_program('scripts/generate_plugins_path.py')
configure_file(
output : 'GstPluginsPath.json',