summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSebastian Fricke <sebastian.fricke@collabora.com>2022-02-17 21:41:40 +0100
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-03-01 11:33:10 +0000
commit0c8ff1a8372518ef45b4b26e411d4f38b9b7e886 (patch)
tree28720de8b9d883269bd04d6f5230b0c9e13dbdd1 /meson.build
parentc999d2c3a904ddadda055b8f4a3654856c80b938 (diff)
downloadgstreamer-0c8ff1a8372518ef45b4b26e411d4f38b9b7e886.tar.gz
Revert "Allow running gst-uninstalled when gst-build is a subproject"
This reverts commit 879126a31c77622f594e70f205fcefd4556d9865. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1743>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 53bdcf56f1..e5cf0e0c3b 100644
--- a/meson.build
+++ b/meson.build
@@ -380,9 +380,9 @@ endif
message('Building subprojects: ' + ', '.join(subprojects_names))
setenv = find_program('gst-env.py')
-devenv_cmd = [setenv, '--builddir=@0@'.format(meson.project_build_root()),
- '--gstbuilddir=@0@'.format(meson.current_build_dir()),
- '--srcdir=@0@'.format(meson.project_source_root())]
+
+devenv_cmd = [setenv, '--builddir=@0@'.format(meson.build_root()),
+ '--srcdir=@0@'.format(meson.source_root())]
subdir('tests')
if meson.can_run_host_binaries() and build_machine.system() == 'linux' and host_machine.system() == 'windows'