summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2006-09-28 11:11:28 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2006-09-28 11:11:28 +0000
commit5ad1430ce9581914e745bbb7277ab1c9171380ca (patch)
tree5405ddbdfd550e8f705a285e132c3a3229760068 /configure.ac
parenta8bbbf2e2de1841059d291edc3e8ebcfaf774d21 (diff)
downloadgstreamer-5ad1430ce9581914e745bbb7277ab1c9171380ca.tar.gz
configure.ac: Don't pull in gmodule-2.0.pc as a dependency in our .pc files - we want gmodule-no-export-2.0.pc instea...
Original commit message from CVS: * configure.ac: Don't pull in gmodule-2.0.pc as a dependency in our .pc files - we want gmodule-no-export-2.0.pc instead so that we don't drag in --export-dynamic on every project that links to GStreamer. Also, make our export regex only match the start of symbols, rather than any symbol that contains '_gst' somewhere. * libs/gst/check/Makefile.am: The libgstcheck we build does however need export-dynamic, as it produces some symbols that don't match our _gst... style regex.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1c0e4e6182..9c34f14d53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,7 +388,7 @@ dnl set location of plugin directory
GST_SET_PLUGINDIR
dnl FIXME: add LIBXML_PKG here
-GST_PKG_DEPS="glib-2.0, gobject-2.0, gmodule-2.0, gthread-2.0"
+GST_PKG_DEPS="glib-2.0, gobject-2.0, gmodule-no-export-2.0, gthread-2.0"
AC_SUBST(GST_PKG_DEPS)
dnl define an ERROR_CFLAGS Makefile variable
@@ -447,7 +447,7 @@ AC_SUBST(GST_ALL_LDFLAGS)
dnl GST_LIB_LDFLAGS
dnl linker flags shared by all libraries
dnl LDFLAGS modifier defining exported symbols from built libraries
-GST_LIB_LDFLAGS="-export-symbols-regex [_]*\(gst_\|Gst\|GST_\).*"
+GST_LIB_LDFLAGS="-export-symbols-regex \^[_]*\(gst_\|Gst\|GST_\).*"
AC_SUBST(GST_LIB_LDFLAGS)
dnl GST_OBJ_*