summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2006-07-21 13:11:33 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2006-07-21 13:11:33 +0000
commit4cb08fa3f282a3a81f808cb6b06e823982815a74 (patch)
treec67e983b6cf20091d2b891e6586c5146d7cb4fd0 /configure.ac
parentc345ebb06a602d884bd2a1c0c675e50e5f57cba3 (diff)
downloadgstreamer-4cb08fa3f282a3a81f808cb6b06e823982815a74.tar.gz
Original commit message from CVS:
* configure.ac: * gst/gstparse.c: (gst_parse_launch):
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 5 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index e38e5d3fe5..6602ed8e6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -236,41 +236,16 @@ AC_PROG_CC
dnl find an assembler
AM_PROG_AS
-dnl we use awk in the bison version check
-AC_PROG_AWK
-
-dnl we require bison for building the parser
-dnl FIXME: check if AC_PROG_YACC is suitable here
-dnl FIXME: make precious
-AC_PATH_PROG(BISON_PATH, bison, no)
-if test x$BISON_PATH = xno; then
- AC_MSG_ERROR(Could not find bison)
-fi
-
-dnl check bison version
-AC_MSG_CHECKING([bison version])
-
-if $BISON_PATH --version | head -n 1 | $AWK '{ if ($4 < 1.35) exit 1; else exit 0;}';
-then
- AC_MSG_RESULT([ok])
-else
- AC_MSG_RESULT([too old.])
- AC_MSG_ERROR([Your bison version is too old, v1.35 or later is required.])
-fi
-
-dnl we require flex for building the parser
-dnl FIXME: check if AC_PROG_LEX is suitable here
-AC_PATH_PROG(FLEX_PATH, flex, no)
-if test x$FLEX_PATH = xno; then
- AC_MSG_ERROR(Could not find flex)
-fi
-
-dnl Perl is used in building documentation
+dnl Perl is used in building documentation and in the version checks
AC_PATH_PROG(PERL_PATH, perl, no)
if test x$PERL_PATH = xno; then
AC_MSG_ERROR(Could not find perl)
fi
+dnl we require flex and bison for building the parser
+GST_BISON_CHECK
+GST_FLEX_CHECK
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")