summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-07 21:28:57 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-07 21:28:57 +0000
commitd2499c35b31d7f23ced543059030e7b7905da6fa (patch)
tree99219435561329f817b2d29a30afaa0c1e9af589 /Makefile.am
parent815fb8543b97c7de1b381192c9f0653409c55779 (diff)
downloadgstreamer-d2499c35b31d7f23ced543059030e7b7905da6fa.tar.gz
Port some changes from 0.6.0/0.6.1 back to HEAD (.pc files moved to pkg-config/, .m4 file moved from plugins to core)
Original commit message from CVS: Port some changes from 0.6.0/0.6.1 back to HEAD (.pc files moved to pkg-config/, .m4 file moved from plugins to core)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 17 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 749da22423..f15b5e0d94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,25 +19,27 @@ else
SUBDIRS_EXAMPLES =
endif
-SUBDIRS = include gst libs tools \
- $(SUBDIRS_TESTS) $(SUBDIRS_EXAMPLES) $(SUBDIRS_DOCS)
-
-# These are all the possible subdirs
-DIST_SUBDIRS = include libs gst tools tests testsuite examples docs
+all-local: gst-element-check-@GST_MAJORMINOR@.m4
-all-local: gstreamer-@GST_MAJORMINOR@.pc gstreamer-@GST_MAJORMINOR@-uninstalled.pc
+gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
+ cp $(srcdir)/gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
-gstreamer-@GST_MAJORMINOR@.pc: gstreamer.pc gstreamer.pc.in
- cp gstreamer.pc gstreamer-@GST_MAJORMINOR@.pc
-gstreamer-@GST_MAJORMINOR@-uninstalled.pc: gstreamer-uninstalled.pc gstreamer-uninstalled.pc.in
- cp gstreamer-uninstalled.pc gstreamer-@GST_MAJORMINOR@-uninstalled.pc
+aclocaldir = $(datadir)/aclocal
+aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gstreamer-@GST_MAJORMINOR@.pc
+SUBDIRS = include gst libs tools \
+ $(SUBDIRS_TESTS) $(SUBDIRS_EXAMPLES) $(SUBDIRS_DOCS) \
+ pkgconfig
-EXTRA_DIST = gstreamer.spec.in \
- gstreamer.pc.in \
- gstreamer-uninstalled.pc.in \
+# These are all the possible subdirs
+DIST_SUBDIRS = include libs gst \
+ tools \
+ tests testsuite \
+ examples \
+ docs \
+ pkgconfig
+
+EXTRA_DIST = gstreamer.spec.in gst-element-check.m4 \
configure.ac autogen.sh depcomp \
REQUIREMENTS ABOUT-NLS RELEASE DOCBUILDING DEVEL \
idiottest.mak common