summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-12 19:10:23 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-12 19:10:23 +0000
commitac6e27ff688c29caaada1ae511f7038b1f5b4f2f (patch)
tree83e8fd66a18c8020dc1100c79ffadf67a73d0735 /Makefile.am
parent80b20e9a0f3af5ca8bb5b48c66bfe1eb6ccaa7ac (diff)
downloadgstreamer-ac6e27ff688c29caaada1ae511f7038b1f5b4f2f.tar.gz
we love 80
Original commit message from CVS: we love 80
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 14 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index d3dadbd086..2dd0347d49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,20 +87,20 @@ GCOV_DIRS=gst libs
## .PHONY so it always rebuilds it
.PHONY: coverage-report.txt
coverage-report.txt:
- BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
- C_FILES= ; \
- for F in $$BBG_FILES ; do \
- F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
- C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g'` ; \
- B=`basename $$F .bbg` ; \
- D=`dirname $$F` ; \
- DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
- DA_libs=`echo $$D/.libs/$$B/.da` ; \
- if test -e $$DA || test -e $$DA_libs; then \
- C_FILES="$$C_FILES $$C" ; \
- fi ; \
- done ; \
- echo $$C_FILES ; \
+ BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
+ C_FILES= ; \
+ for F in $$BBG_FILES ; do \
+ F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
+ C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g'` ; \
+ B=`basename $$F .bbg` ; \
+ D=`dirname $$F` ; \
+ DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
+ DA_libs=`echo $$D/.libs/$$B/.da` ; \
+ if test -e $$DA || test -e $$DA_libs; then \
+ C_FILES="$$C_FILES $$C" ; \
+ fi ; \
+ done ; \
+ echo $$C_FILES ; \
$(top_builddir)/testsuite/decode-gcov --report $$C_FILES > coverage-report.txt
check-coverage: clean-gcov all check coverage-report.txt