summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-06 13:07:20 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-06 13:07:20 +0000
commita4e5d02aef0ae7d85b9fb4c788fc54b747af33e1 (patch)
treed244b30b4bf2150f9fa586f3cfcc7cbdaac8b7fd /Makefile.am
parent5cafe6cc17cf6aa1911bdebfc47d7fb90dfbabd4 (diff)
downloadgstreamer-a4e5d02aef0ae7d85b9fb4c788fc54b747af33e1.tar.gz
bump nano add release target
Original commit message from CVS: bump nano add release target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 244d02bd03..d3dadbd086 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,12 +45,26 @@ DIST_SUBDIRS = include libs gst \
EXTRA_DIST = gstreamer.spec.in gst-element-check.m4 \
configure.ac autogen.sh depcomp \
- REQUIREMENTS ABOUT-NLS RELEASE DOCBUILDING DEVEL \
+ REQUIREMENTS ABOUT-NLS DOCBUILDING DEVEL \
idiottest.mak common
CLEANFILES = gst-element-check-@GST_MAJORMINOR@.m4
+# to do a release, run "make release"
+# this will generate all archives and md5sums
+
+# make bz2 as well
+AUTOMAKE_OPTIONS = dist-bzip2
+
+release: dist
+ make @PACKAGE@-@VERSION@.tar.gz.md5
+ make @PACKAGE@-@VERSION@.tar.bz2.md5
+
+# generate md5 sum files
+%.md5: %
+ md5sum $< > $@
+
dist-hook:
cp gstreamer.spec $(distdir)
rm -rf `find $(distdir)/common -name CVS`