summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-08-13 14:03:05 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-08-13 14:03:05 +0000
commit756dc098f7e2ac55921444d77d501d6440b456fc (patch)
tree5f3721cad4bb0b30459cf99db09e09f3ff45c667 /Makefile.am
parent2797299404c72f996f403266496d54704413a52e (diff)
downloadgstreamer-756dc098f7e2ac55921444d77d501d6440b456fc.tar.gz
add win32 - fixes 149981
Original commit message from CVS: add win32 - fixes 149981
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index cb0305c4fe..aa4111ecb7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,14 +29,16 @@ ACLOCAL_AMFLAGS = -I common/m4
aclocaldir = $(datadir)/aclocal
aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
-SUBDIRS = include gst libs tools \
+SUBDIRS = \
+ include gst libs tools \
$(SUBDIRS_TESTS) $(SUBDIRS_EXAMPLES) \
pkgconfig po \
common \
$(SUBDIRS_DOCS)
# These are all the possible subdirs
-DIST_SUBDIRS = include libs gst \
+DIST_SUBDIRS = \
+ include libs gst \
tools \
tests testsuite \
examples \
@@ -45,10 +47,16 @@ DIST_SUBDIRS = include libs gst \
common \
docs
-EXTRA_DIST = gstreamer.spec gstreamer.spec.in gst-element-check.m4 \
- configure.ac autogen.sh depcomp \
- REQUIREMENTS ABOUT-NLS DOCBUILDING DEVEL RELEASE \
- idiottest.mak
+win32 = $(shell cat $(top_srcdir)/win32/MANIFEST)
+
+debug:
+ echo $(win32)
+EXTRA_DIST = \
+ gstreamer.spec gstreamer.spec.in gst-element-check.m4 \
+ configure.ac autogen.sh depcomp \
+ REQUIREMENTS ABOUT-NLS DOCBUILDING DEVEL RELEASE \
+ $(win32) \
+ idiottest.mak
CLEANFILES = gst-element-check-@GST_MAJORMINOR@.m4