summaryrefslogtreecommitdiff
path: root/gst/matroska/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/matroska/Makefile.am')
-rw-r--r--gst/matroska/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/gst/matroska/Makefile.am b/gst/matroska/Makefile.am
index 5efbf4eb0..195c68057 100644
--- a/gst/matroska/Makefile.am
+++ b/gst/matroska/Makefile.am
@@ -39,3 +39,18 @@ libgstmatroska_la_LIBADD = \
$(LIBM)
libgstmatroska_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstmatroska_la_LIBTOOLFLAGS = --tag=disable-static
+
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstmatroska -:SHARED libgstmatroska \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstmatroska_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(CPPFLAGS) $(libgstmatroska_la_CFLAGS) \
+ -:LDFLAGS $(libgstmatroska_la_LDFLAGS) \
+ $(libgstmatroska_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@