summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <niels.degraef@barco.com>2019-05-31 23:04:11 +0200
committerNicolas Dufresne <nicolas@ndufresne.ca>2019-06-03 16:18:55 +0000
commitf3970565f05e90af88604cc525e2774581f8dce9 (patch)
treedce58a4d7b2672363ff327b8ca4434e7ae6bf289 /meson.build
parent2bed2687bbe70263e5ebeb35b0b10da27eb8cb4f (diff)
downloadgstreamer-plugins-good-f3970565f05e90af88604cc525e2774581f8dce9.tar.gz
meson: Bump minimal GLib version to 2.44
This means we can use some newer features and get rid of some boilerplate code using the G_DECLARE_* macros. As discussed on IRC, 2.44 is old enough by now to start depending on it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5022483ef..b967cb810 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,7 @@ gst_version_is_dev = gst_version_minor % 2 == 1 and gst_version_micro < 90
# FIXME: automagic
have_cxx = add_languages('cpp', required : false)
-glib_req = '>= 2.40.0'
+glib_req = '>= 2.44.0'
orc_req = '>= 0.4.17'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)