summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-05-21 11:35:05 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-05-21 11:35:05 +0100
commitd3bd3e04004d682a8c5f07e69fb20f61dc5a8871 (patch)
tree08e5c3d0f8615d3bbfc418c114c2e4b271e8b131 /meson.build
parent9c92ae89c7794d781eb3e953be53ca8b2ff99757 (diff)
downloadgstreamer-plugins-base-d3bd3e04004d682a8c5f07e69fb20f61dc5a8871.tar.gz
meson: add install_plugins_helper option
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 21a57e533..2d1a2b9c7 100644
--- a/meson.build
+++ b/meson.build
@@ -121,10 +121,17 @@ core_conf.set_quoted('PACKAGE', 'gst-plugins-base')
core_conf.set_quoted('VERSION', gst_version)
core_conf.set_quoted('PACKAGE_VERSION', gst_version)
core_conf.set_quoted('GST_API_VERSION', api_version)
-core_conf.set_quoted('GST_INSTALL_PLUGINS_HELPER', 'FIXME')
core_conf.set_quoted('GST_DATADIR', join_paths(get_option('prefix'), get_option('datadir')))
core_conf.set_quoted('GST_LICENSE', 'LGPL')
+install_plugins_helper = get_option('install_plugins_helper')
+if install_plugins_helper == ''
+ install_plugins_helper = join_paths(get_option('prefix'),
+ get_option('libexecdir'),
+ 'gst-install-plugins-helper')
+endif
+core_conf.set_quoted('GST_INSTALL_PLUGINS_HELPER', install_plugins_helper)
+
warning_flags = [
'-Wmissing-declarations',
'-Wredundant-decls',