summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-07-31 23:32:42 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-07-31 23:32:42 +0530
commitbe79f74c4df7773d65a7e7c69801884172280359 (patch)
tree5b3062dd03d74238eee6a391d6b408c172d61480 /meson.build
parent28caf92587f686655675cfdd24d5aa9271c0214c (diff)
downloadgstreamer-plugins-base-be79f74c4df7773d65a7e7c69801884172280359.tar.gz
meson: Fix build with x11 dependency is disabled
gtk_x11_dep is used unconditionally in tests/icles/meson.build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4393440fa..9198b6d4e 100644
--- a/meson.build
+++ b/meson.build
@@ -222,6 +222,8 @@ gtk_dep = dependency('gtk+-3.0', version : '>= 3.10', required : get_option('exa
# TODO: https://github.com/mesonbuild/meson/issues/3941
if not get_option('x11').disabled()
gtk_x11_dep = dependency('gtk+-x11-3.0', version : '>= 3.10', required : get_option('examples'))
+else
+ gtk_x11_dep = dependency('', required : false)
endif
# gtk+ quartz backend is only available on macOS
if host_system == 'darwin'