summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2018-04-24 14:05:57 -0400
committerTim-Philipp Müller <tim@centricular.com>2018-04-25 11:05:56 +0100
commit201e7c7803bf3c159c9b4c0b1ee5c7f66d106fd2 (patch)
tree2434dc4ff1e87ea6d841ce40c67f8c04fd1d2965 /meson.build
parent447942c63d3fd18745e0e76ed4b052266f673e50 (diff)
downloadgstreamer-plugins-base-201e7c7803bf3c159c9b4c0b1ee5c7f66d106fd2.tar.gz
Meson: Generate pc file for all plugins in base
https://bugzilla.gnome.org/show_bug.cgi?id=794568
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bb41d44c4..48a3da215 100644
--- a/meson.build
+++ b/meson.build
@@ -311,6 +311,13 @@ gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' +
'g_setenv("GST_PLUGIN_SYSTEM_PATH_1_0", "", TRUE);' + \
'gst_init(NULL,NULL);' ]
+pkgconfig = import('pkgconfig')
+plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
+if get_option('default_library') == 'shared'
+ # If we don't build static plugins there is no need to generate pc files
+ plugins_pkgconfig_install_dir = disabler()
+endif
+
subdir('gst-libs')
subdir('gst')
subdir('ext')