summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-01-30 20:23:24 +0000
committerBenjamin Otte <otte@gnome.org>2004-01-30 20:23:24 +0000
commitebed8d8724839a3b2e056a620f241fec6b71ce94 (patch)
tree3fd6a3bf5aba74d81495c4bfb3dc5574ad6c2a40 /ext/Makefile.am
parent184abd52fe9caa80b0d440d9b0198e40e64dafbc (diff)
downloadgstreamer-plugins-base-ebed8d8724839a3b2e056a620f241fec6b71ce94.tar.gz
configure.ac: use AC_C_INLINE
Original commit message from CVS: 2004-01-30 Benjamin Otte <in7y118@public.uni-hamburg.de> * configure.ac: use AC_C_INLINE * configure.ac: * ext/Makefile.am: * ext/theora/Makefile.am: * ext/theora/theoradec.c: add theora video decoder. Does just do simple decoding for now and has been tested against Theora cvs only. * ext/vorbis/vorbisdec.c: (vorbis_dec_event): always reset packetno on DISCONT
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 0e091de57..182ac56a7 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -298,6 +298,12 @@ else
VORBIS_DIR=
endif
+if USE_THEORA
+THEORA_DIR=theora
+else
+THEORA_DIR=
+endif
+
if USE_XVID
XVID_DIR=xvid
else
@@ -366,6 +372,7 @@ SUBDIRS=\
$(SPEEX_DIR) \
$(SWFDEC_DIR) \
$(TARKIN_DIR) \
+ $(THEORA_DIR) \
$(IVORBIS_DIR) \
$(VORBIS_DIR) \
$(XVID_DIR)
@@ -422,5 +429,6 @@ DIST_SUBDIRS=\
speex \
swfdec \
tarkin \
+ theora \
vorbis \
xvid