summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-04-29 00:00:25 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-04-29 00:00:25 +0000
commitaa31694595115041a5dfa68c34ef2cbfdbe080ca (patch)
tree249984c10d43c07e932a521bca40d7e2d79c4875 /ext/Makefile.am
parentcf31f62b174414aa6ef67bb9d6173c978f64e450 (diff)
downloadgstreamer-plugins-base-aa31694595115041a5dfa68c34ef2cbfdbe080ca.tar.gz
New DTS decoder.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/dts/Makefile.am: * ext/dts/gstdtsdec.c: (gst_dtsdec_get_type), (gst_dtsdec_base_init), (gst_dtsdec_class_init), (gst_dtsdec_init), (gst_dtsdec_channels), (gst_dtsdec_renegotiate), (gst_dtsdec_handle_event), (gst_dtsdec_update_streaminfo), (gst_dtsdec_loop), (gst_dtsdec_change_state), (gst_dtsdec_set_property), (gst_dtsdec_get_property), (plugin_init): * ext/dts/gstdtsdec.h: New DTS decoder. * ext/faad/gstfaad.c: (gst_faad_sinkconnect), (gst_faad_srcconnect): Add ESDS atom handling (.m4a).
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index bff4e4bfb..be9169dba 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -46,6 +46,12 @@ else
DIVX_DIR=
endif
+if USE_DTS
+DTS_DIR=dvdread
+else
+DTS_DIR=
+endif
+
if USE_DVDREAD
DVDREAD_DIR=dvdread
else
@@ -331,6 +337,7 @@ SUBDIRS=\
$(AUDIOFILE_DIR) \
$(CDPARANOIA_DIR) \
$(DIVX_DIR) \
+ $(DTS_DIR) \
$(DVDREAD_DIR) \
$(DVDNAV_DIR) \
$(ESD_DIR) \
@@ -386,6 +393,7 @@ DIST_SUBDIRS=\
audiofile \
cdparanoia \
divx \
+ dts \
dv \
dvdread \
dvdnav \