summaryrefslogtreecommitdiff
path: root/gst/timecode/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gst/timecode/meson.build')
-rw-r--r--gst/timecode/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/gst/timecode/meson.build b/gst/timecode/meson.build
index 28d560b76..d456ae3f4 100644
--- a/gst/timecode/meson.build
+++ b/gst/timecode/meson.build
@@ -6,6 +6,12 @@ timecode_sources = [
tc_deps = [gstbase_dep, gstaudio_dep, gstvideo_dep]
+ltc_dep = dependency('ltc', version : '>=1.1.4', required : false)
+if ltc_dep.found()
+ cdata.set('HAVE_LTC', 1)
+ tc_deps += [ltc_dep]
+endif
+
gsttimecode = library('gsttimecode',
timecode_sources,
c_args : gst_plugins_bad_args,