summaryrefslogtreecommitdiff
path: root/gst/camerabin2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/camerabin2/Makefile.am')
-rw-r--r--gst/camerabin2/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/gst/camerabin2/Makefile.am b/gst/camerabin2/Makefile.am
index 3433263ad..011ea7847 100644
--- a/gst/camerabin2/Makefile.am
+++ b/gst/camerabin2/Makefile.am
@@ -13,9 +13,9 @@ libgstcamerabin2_la_CFLAGS = \
-DGST_USE_UNSTABLE_API
libgstcamerabin2_la_LIBADD = \
- $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-$(GST_MAJORMINOR).la \
- $(top_builddir)/gst-libs/gst/basecamerabinsrc/libgstbasecamerabinsrc-$(GST_MAJORMINOR).la \
- $(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-$(GST_MAJORMINOR) -lgsttag-$(GST_MAJORMINOR) -lgstapp-$(GST_MAJORMINOR) -lgstpbutils-$(GST_MAJORMINOR) \
+ $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-$(GST_API_VERSION).la \
+ $(top_builddir)/gst-libs/gst/basecamerabinsrc/libgstbasecamerabinsrc-$(GST_API_VERSION).la \
+ $(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-$(GST_API_VERSION) -lgsttag-$(GST_API_VERSION) -lgstapp-$(GST_API_VERSION) -lgstpbutils-$(GST_API_VERSION) \
$(GST_BASE_LIBS) $(GST_LIBS)
libgstcamerabin2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
@@ -36,8 +36,8 @@ Android.mk: Makefile.am $(BUILT_SOURCES)
-:LDFLAGS $(libgstcamerabin2_la_LDFLAGS) \
$(libgstcamerabin2_la_LIBADD) \
-ldl \
- -:LIBFILTER_STATIC gstphotography-@GST_MAJORMINOR@ \
- gstbasecamerabinsrc-@GST_MAJORMINOR@ \
+ -:LIBFILTER_STATIC gstphotography-@GST_API_VERSION@ \
+ gstbasecamerabinsrc-@GST_API_VERSION@ \
-:PASSTHROUGH LOCAL_ARM_MODE:=arm \
LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
> $@