summaryrefslogtreecommitdiff
path: root/ext/opus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/opus/Makefile.am')
-rw-r--r--ext/opus/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/ext/opus/Makefile.am b/ext/opus/Makefile.am
index cdf3c30ac..48a7eade4 100644
--- a/ext/opus/Makefile.am
+++ b/ext/opus/Makefile.am
@@ -3,13 +3,13 @@ plugin_LTLIBRARIES = libgstopus.la
libgstopus_la_SOURCES = gstopus.c gstopusdec.c gstopusenc.c gstopusparse.c gstopusheader.c gstopuscommon.c gstrtpopuspay.c gstrtpopusdepay.c
libgstopus_la_CFLAGS = \
-DGST_USE_UNSTABLE_API \
+ $(GST_PLUGINS_BAD_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS) \
$(GST_CFLAGS) \
$(OPUS_CFLAGS)
libgstopus_la_LIBADD = \
- -lgstaudio-$(GST_MAJORMINOR) \
- $(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) \
- -lgstrtp-@GST_MAJORMINOR@ \
+ $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) \
+ -lgsttag-$(GST_MAJORMINOR) -lgstrtp-$(GST_MAJORMINOR) \
$(GST_BASE_LIBS) \
$(GST_LIBS) \
$(OPUS_LIBS)