summaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
deleted file mode 100644
index fc94f03..0000000
--- a/pkgconfig/Makefile.am
+++ /dev/null
@@ -1,31 +0,0 @@
-### all of the standard pc files we need to generate
-pcverfiles = \
- gstreamer-plugins-libav-@GST_API_VERSION@.pc
-pcverfiles_uninstalled = \
- gstreamer-plugins-libav-@GST_API_VERSION@-uninstalled.pc
-
-### all-local: $(pcverfiles) $(pcverfiles_uninstalled)
-all-local: $(pcverfiles_uninstalled)
-
-cp_verbose = $(cp_verbose_$(V))
-cp_verbose_ = $(cp_verbose_$(AM_DEFAULT_VERBOSITY))
-cp_verbose_0 = @echo " CP $@";
-
-### how to generate versioned .pc files from .pc files in this dir
-%-@GST_API_VERSION@.pc: %.pc
- $(cp_verbose)cp $< $@
-%-@GST_API_VERSION@-uninstalled.pc: %-uninstalled.pc
- $(cp_verbose)cp $< $@
-
-# do not install for now
-# pkgconfigdir = $(libdir)/pkgconfig
-# pkgconfig_DATA = $(pcverfiles)
-
-CLEANFILES = $(pcverfiles) $(pcverfiles_uninstalled)
-# pcinfiles = \
-# gstreamer-plugins-libav.pc.in gstreamer-plugins-libav-uninstalled.pc.in
-pcinfiles = \
- gstreamer-plugins-libav-uninstalled.pc.in
-
-DISTCLEANFILES = $(pcinfiles:.in=)
-EXTRA_DIST = $(pcinfiles)