summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1e694d9..4d736f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,7 +285,6 @@ if test "x$with_system_libav" = "xyes"; then
saved_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $LIBAV_CFLAGS"
AC_CHECK_HEADERS([avi.h])
- CPPFLAGS="$saved_CPPFLAGS"
AC_DEFINE([LIBAV_SOURCE], ["system install"], [Describes where the Libav libraries come from.])
HAVE_LIBAV_UNINSTALLED=0
AC_MSG_NOTICE([Using system-installed libav code])
@@ -300,6 +299,7 @@ if test "x$with_system_libav" = "xyes"; then
#endif
]])], [is_ffmpeg=yes], [is_ffmpeg=no])
AC_MSG_RESULT([$is_ffmpeg])
+ CPPFLAGS="$saved_CPPFLAGS"
if test "$is_ffmpeg" = no; then
AC_MSG_ERROR([Uncompatible libavcodec found])
fi