summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2016-08-29 11:08:16 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-05 12:44:37 -0300
commitf6c31d1cb69a3ce907bc0513cfcb5025f5b97345 (patch)
tree45b832a373dcc5f1652ee1640deecce7732c97b4 /meson.build
parentf5f32986b624816e9ca478c3c413c03dff584e0f (diff)
downloadgst-libav-f6c31d1cb69a3ce907bc0513cfcb5025f5b97345.tar.gz
build: Do not link plugin against lzma and bz2 if using system install
And bump version to 1.9.2
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 2 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index 08d865a..2d335b6 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('gst-libav', 'c', 'cpp',
- version : '1.9.1.1',
+ version : '1.9.2.1',
meson_version : '>= 0.33.0',
default_options : [ 'warning_level=1',
'c_std=gnu99',
@@ -26,7 +26,7 @@ check_ffmpeg_src = '''#include <libavcodec/avcodec.h>
#error libav provider should be FFmpeg
#endif'''
-if not cc.compiles(check_ffmpeg_src, name : 'whether libav is provided by FFmpeg')
+if not cc.compiles(check_ffmpeg_src, name : 'libav is provided by FFmpeg')
error('Uncompatible libavcodec found')
endif
@@ -49,20 +49,6 @@ gstpbutils_dep = dependency('gstreamer-pbutils-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'pbutils_dep'])
libm = cc.find_library('m', required : false)
-bz2lib = cc.find_library('bz2', required : false)
-if bz2lib.found()
- cdata.set('HAVE_BZ2', 1)
-else
- message('WARN: libbz2 not found, matroska demuxer will not be able to read bz2 tracks')
-endif
-
-lzmalib = cc.find_library('lzma', required : false)
-if lzmalib.found()
- cdata.set('HAVE_LZMA', 1)
-else
- message('WARN: lzma not found, tiff reader will not be able to read lzma files')
-endif
-
configure_file(input : 'config.h.meson',
output : 'config.h',
configuration : cdata)