summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@gnome.org>2016-12-09 17:42:36 -0300
committerThibault Saunier <tsaunier@gnome.org>2016-12-09 17:51:34 -0300
commitf5b6d274e21c3ddf4a136447927bde8280e6f9c9 (patch)
treef9f49836bb644e78d86ee51fc9cbfb529bda0a53 /meson.build
parenta7b62f8d934487263ad76094cef67ca2643d22ab (diff)
downloadgst-libav-f5b6d274e21c3ddf4a136447927bde8280e6f9c9.tar.gz
meson: Support building without Gst debug
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fdf9348..bc5a972 100644
--- a/meson.build
+++ b/meson.build
@@ -73,6 +73,30 @@ else
language : 'c')
endif
+if gst_dep.type_name() == 'internal'
+ gst_proj = subproject('gstreamer')
+
+ if gst_proj.get_variable('disable_gst_debug')
+ message('GStreamer debug system is disabled')
+ add_project_arguments('-Wno-unused', language: 'c')
+ else
+ message('GStreamer debug system is enabled')
+ endif
+else
+ # We can't check that in the case of subprojects as we won't
+ # be able to build against an internal dependency (which is not built yet)
+ if not cc.compiles('''
+#include <gst/gstconfig.h>
+#ifdef GST_DISABLE_GST_DEBUG
+#error "debugging disabled, make compiler fail"
+#endif''' , dependencies: gst_dep)
+ message('GStreamer debug system is disabled')
+ add_project_arguments('-Wno-unused', language: 'c')
+ else
+ message('GStreamer debug system is enabled')
+ endif
+endif
+
configinc = include_directories('.')
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
subdir('ext/libav/')