summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2016-11-23 06:04:58 -0800
committerThibault Saunier <tsaunier@gnome.org>2016-11-25 13:22:34 -0300
commit863f2c7bb10b8c701bb05d8f1dcd34edd5de9034 (patch)
tree474b16c3ec665bf1d43e60185355906e5b6bfb10 /meson.build
parent9258b8ba53ad90776113055ec759eeaa04ef0163 (diff)
downloadgst-libav-863f2c7bb10b8c701bb05d8f1dcd34edd5de9034.tar.gz
Properly check if unistd.h is avalaible
And stop providing a meson.h.config as it is not needed (as meson dep has been bumped to 0.36)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index f60ccc4..c77cdcf 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-libav', 'c', 'cpp',
version : '1.11.0.1',
- meson_version : '>= 0.33.0',
+ meson_version : '>= 0.36.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -33,6 +33,13 @@ cdata = configuration_data()
cdata.set('LIBAV_SOURCE', '"system install"')
cdata.set('PACKAGE_VERSION', '"@0@"'.format(gst_version))
cdata.set('PACKAGE', '"gst-libav"')
+check_headers = [['unistd.h', 'HAVE_UNISTD_H']]
+
+foreach h : check_headers
+ if cc.has_header(h.get(0))
+ cdata.set(h.get(1), 1)
+ endif
+endforeach
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
gst_dep = dependency('gstreamer-1.0', version : gst_req,
@@ -48,9 +55,7 @@ gstpbutils_dep = dependency('gstreamer-pbutils-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'pbutils_dep'])
libm = cc.find_library('m', required : false)
-configure_file(input : 'config.h.meson',
- output : 'config.h',
- configuration : cdata)
+configure_file(output : 'config.h', configuration : cdata)
gst_libav_args = ['-DHAVE_CONFIG_H', '-Wno-deprecated-declarations']
configinc = include_directories('.')