summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-05-05 20:03:49 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-05-05 20:32:15 +0530
commit720fc4ffef70b6b70014119d76414967747e4ada (patch)
treeccc6ad248e4f89e7e6df04a1718024cd55aca11f /meson.build
parentca522652ed0b27d7b648b0bfd334ec3e6e7a23d3 (diff)
downloadgst-libav-720fc4ffef70b6b70014119d76414967747e4ada.tar.gz
meson: Update option names to omit disable_ and with- prefixes
Also yield common options to the outer project (gst-build in our case) so that they don't have to be set manually.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0e61345..cd76c72 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-libav', 'c', 'cpp',
version : '1.15.0.1',
- meson_version : '>= 0.36.0',
+ meson_version : '>= 0.46.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -41,7 +41,7 @@ cdata.set('PACKAGE_VERSION', '"@0@"'.format(gst_version))
cdata.set('PACKAGE', '"gst-libav"')
# GStreamer package name and origin url
-gst_package_name = get_option('with-package-name')
+gst_package_name = get_option('package-name')
if gst_package_name == ''
if gst_version_nano == 0
gst_package_name = 'GStreamer FFMPEG Plug-ins source release'
@@ -52,7 +52,7 @@ if gst_package_name == ''
endif
endif
cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
-cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
+cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('package-origin'))
check_headers = [['unistd.h', 'HAVE_UNISTD_H']]
@@ -108,7 +108,7 @@ endif
if gst_dep.type_name() == 'internal'
gst_proj = subproject('gstreamer')
- if gst_proj.get_variable('disable_gst_debug')
+ if not gst_proj.get_variable('gst_debug')
message('GStreamer debug system is disabled')
add_project_arguments('-Wno-unused', language: 'c')
else