summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2018-10-22 11:41:07 +0200
committerThibault Saunier <tsaunier@igalia.com>2019-05-13 17:00:00 -0400
commit357a9b4a19c68c8a547d23a069cb2bf53ec32db1 (patch)
treefa66723792c0b3de8cf81792aa6f449afd211c43 /meson.build
parent5705e4ea7d8db911bd35f5ee26f7286ea3470b08 (diff)
downloadgst-libav-357a9b4a19c68c8a547d23a069cb2bf53ec32db1.tar.gz
docs: Port to hotdoc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 67b31ee..95aea47 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-libav', 'c', 'cpp',
version : '1.17.0.1',
- meson_version : '>= 0.46.0',
+ meson_version : '>= 0.48.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -15,6 +15,7 @@ else
gst_version_nano = 0
endif
+api_version = '1.0'
libavfilter_dep = dependency('libavfilter', version: '>= 7.16.100',
fallback: ['FFmpeg', 'libavfilter_dep'])
libavformat_dep = dependency('libavformat', version: '>= 58.12.100',
@@ -175,13 +176,17 @@ endforeach
configinc = include_directories('.')
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
+
pkgconfig = import('pkgconfig')
plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
if get_option('default_library') == 'shared'
# If we don't build static plugins there is no need to generate pc files
plugins_pkgconfig_install_dir = disabler()
endif
+
+plugins = []
subdir('ext/libav')
+subdir('docs')
python3 = import('python').find_installation()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')