summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-08-11 20:26:06 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-08-11 20:26:10 +0100
commit28cc05ac1da46c00e19efa5b16d4bdd76da7a34b (patch)
treec405ce6fbd546eadd742e5a645c2b289ae97d136 /meson.build
parent5b22802b353c6e7c5a43e3f8567d5ac94f8de6ff (diff)
downloadgst-libav-28cc05ac1da46c00e19efa5b16d4bdd76da7a34b.tar.gz
meson: don't export symbols by default
Only plugin entry points should be exported.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dfb23d1..39c3859 100644
--- a/meson.build
+++ b/meson.build
@@ -91,6 +91,11 @@ else
language : 'c')
endif
+# Symbol visibility
+if cc.has_argument('-fvisibility=hidden')
+ add_project_arguments('-fvisibility=hidden', language: 'c')
+endif
+
if gst_dep.type_name() == 'internal'
gst_proj = subproject('gstreamer')