summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <jan@centricular.com>2017-05-20 20:02:39 +1000
committerJan Schmidt <jan@centricular.com>2017-05-20 20:08:09 +1000
commitac9fc8031e001a3c4a9b4ba8fdfe8b0b3da22823 (patch)
tree59aa6b37760e5a10db955cf860f8b2be0794dafa /configure.ac
parent8e2b41f3b0bbdc9fc1aa7e0aabdf9b39da5cad09 (diff)
downloadgst-libav-ac9fc8031e001a3c4a9b4ba8fdfe8b0b3da22823.tar.gz
Pass $CC as AS, unless $AS is provided. Add gas-preprocessor
Add gas-preprocessor.pl as a git submodule, and put it in the path so that it is available if libav wants it. Switch back to providing $CC as $AS by default, but respect an external $AS setting so that it can be overridden in cerbero https://bugzilla.gnome.org/show_bug.cgi?id=694416
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3a73678..6039592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,8 @@ dnl we override it here if we need to for the release candidate of new series
GST_API_VERSION=1.0
AC_SUBST(GST_API_VERSION)
+dnl *** Check for external $AS vs detected by AS_LIBTOOL
+user_AS="$AS"
AG_GST_LIBTOOL_PREPARE
AS_LIBTOOL(GST, 1300, 0, 1300)
@@ -385,8 +387,11 @@ else
emblibav_configure_args="$emblibav_configure_args --ar=\\\"\\\$AR\\\""
fi
- if test x"$AS" != x; then
- emblibav_configure_args="$emblibav_configure_args --as=\\\"\\\$AS\\\""
+ if test x"$orig_AS" != x; then
+ emblibav_configure_args="$emblibav_configure_args --as=\\\"\\\$orig_AS\\\""
+ elif test x"$CC" != x; then
+ dnl No external $AS - try $CC for the libav assembler
+ emblibav_configure_args="$emblibav_configure_args --as=\\\"\\\$CC\\\""
fi
if test x"$CC" != x; then
@@ -430,14 +435,19 @@ else
dnl to detect out-of-tree builds
if test -z "$srcdir" -o "$srcdir" = .; then
confcmd=./configure
+ gasppdir=../gas-preprocessor
else
confcmd="$ac_abs_top_srcdir"/gst-libs/ext/libav/configure
+ gasppdir="$ac_abs_top_srcdir"/gst-libs/ext/gas-preprocessor
fi
AS_MKDIR_P(["$ac_top_build_prefix"gst-libs/ext/libav])
+ oldPATH="$PATH"
+ PATH="$gasppdir:$PATH"
cd "$ac_top_build_prefix"gst-libs/ext/libav &&
eval "$confcmd $emblibav_configure_args" ||
AC_MSG_ERROR([Failed to configure embedded Libav tree])
+ PATH="$oldPATH"
cd "$origdir"
],
[emblibav_configure_args="$emblibav_configure_args"])