summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-16 14:43:11 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-16 14:43:11 -0400
commita65562fe9cce9606ef1bb8e7e6830adc4d213178 (patch)
tree89dbed82bb6eb0c643ec6d698114e0eb01cae620 /configure.ac
parent15a17f3f8d2282005e746507f833e68947e736e3 (diff)
downloadgst-libav-a65562fe9cce9606ef1bb8e7e6830adc4d213178.tar.gz
Remove plugin specific static build option
Static and dynamic plugins now have the same interface. The standard --enable-static/--enable-shared toggle are sufficient.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 3 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 86174f3..3a73678 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,27 +152,9 @@ dnl *** set variables based on configure arguments ***
dnl set location of plugin directory
AG_GST_SET_PLUGINDIR
-dnl build static plugins or not
-AC_MSG_CHECKING([whether to build static plugins or not])
-AC_ARG_ENABLE(
- static-plugins,
- AC_HELP_STRING(
- [--enable-static-plugins],
- [build static plugins @<:@default=no@:>@]),
- [AS_CASE(
- [$enableval], [no], [], [yes], [],
- [AC_MSG_ERROR([bad value "$enableval" for --enable-static-plugins])])],
- [enable_static_plugins=no])
-AC_MSG_RESULT([$enable_static_plugins])
-if test "x$enable_static_plugins" = xyes; then
- AC_DEFINE(GST_PLUGIN_BUILD_STATIC, 1,
- [Define if static plugins should be built])
- GST_PLUGIN_LIBTOOLFLAGS=""
-else
- GST_PLUGIN_LIBTOOLFLAGS="--tag=disable-static"
-fi
-AC_SUBST(GST_PLUGIN_LIBTOOLFLAGS)
-AM_CONDITIONAL(GST_PLUGIN_BUILD_STATIC, test "x$enable_static_plugins" = "xyes")
+dnl Detect if we are building static plugins, in which case we need to
+dnl generates libav .la files and install the static libraries.
+AM_CONDITIONAL(GST_PLUGIN_BUILD_STATIC, test "x$enable_static" = "xyes")
dnl define an ERROR_CFLAGS Makefile variable
AG_GST_SET_ERROR_CFLAGS($FATAL_WARNINGS, [