summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2016-11-10 15:42:19 +0100
committerSebastian Dröge <sebastian@centricular.com>2016-11-10 17:30:16 +0200
commit83ff353ff96e3191496909f6327bb047150cfac4 (patch)
treee75de9c613ffd0d6f1dd69c4030894687f8e6672 /configure.ac
parent88da0fb9563bc94cb8293af7fed024d44f09cb73 (diff)
downloadgst-libav-83ff353ff96e3191496909f6327bb047150cfac4.tar.gz
configure: fix target_os when cross-compiling for arm
For arm 'host_os' is '*-gnueabi' or '*-gnueabihf' so sed needs to cut of more. Otherwise configuring ffmpeg will fail with "Unknown OS 'linuxeabi'." or something like that. https://bugzilla.gnome.org/show_bug.cgi?id=774215
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 17825f0..2a4a57d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -384,7 +384,7 @@ else
target_os=darwin
;;
*)
- target_os=`echo $host_os | sed 's/-gnu//'`
+ target_os=`echo $host_os | sed 's/-gnu.*//'`
;;
esac