summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <jan@centricular.com>2018-04-28 00:14:45 +1000
committerJan Schmidt <jan@centricular.com>2018-05-01 14:42:10 +1000
commit7f11e32e8bea2643336941400784b647717e1f5a (patch)
tree7664ded24db72c6b454c617afca896b4dcbe9bc4 /configure.ac
parentfce1bb56e2866c581bf655304b9029a115cc2946 (diff)
downloadgst-libav-7f11e32e8bea2643336941400784b647717e1f5a.tar.gz
configure: fix handling of the input AS var passed to ffmpeg
Store the original AS environment variable passed to configure correctly, and export it so it's actually available to the sub-process when configuring the embedded ffmpeg
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a0a1653..2b02d47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,7 @@ GST_API_VERSION=1.0
AC_SUBST(GST_API_VERSION)
dnl *** Check for external $AS vs detected by AS_LIBTOOL
-user_AS="$AS"
+orig_AS="$AS"
AG_GST_LIBTOOL_PREPARE
AS_LIBTOOL(GST, 1500, 0, 1500)
@@ -406,6 +406,7 @@ else
if test x"$orig_AS" != x; then
emblibav_configure_args="$emblibav_configure_args --as=\\\"\\\$orig_AS\\\""
+ export orig_AS
elif test x"$CC" != x; then
dnl No external $AS - try $CC for the libav assembler
emblibav_configure_args="$emblibav_configure_args --as=\\\"\\\$CC\\\""