summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-20 15:27:52 +0200
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-20 15:27:52 +0200
commit7b0a5ad30981d28dba7a7415ee7e9e2d384780e2 (patch)
tree6db7c31e404d3d39be69571eeb046c7e98c2786b /configure.ac
parent321d1c7a7552c2f0466c05ca22e4379cd028b7a1 (diff)
downloadgst-libav-7b0a5ad30981d28dba7a7415ee7e9e2d384780e2.tar.gz
plugin: Explicitly link to BZ2, LZMA and LZ
While all this information is in the .la files, libtool seems to get confused with ordering in presence of static system libraries. This could cause missing symbol error at link time. Adding these depenencies explicitly workaround the issue.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6039592..1ee3c27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,6 +280,9 @@ else
LIBS=$save_LIBS
if test "x$HAVE_BZ2" = "xno"; then
AC_WARN([libbz2 not found, matroska demuxer will not be able to read bz2 tracks])
+ BZ2_LIBS=
+ else
+ BZ2_LIBS="-lbz2"
fi
dnl *** Check for lzma
@@ -291,6 +294,9 @@ else
LIBS=$save_LIBS
if test "x$HAVE_LZMA" = "xno"; then
AC_WARN([lzma not found, tiff reader will not be able to read lzma files])
+ LZMA_LIBS=
+ else
+ LZMA_LIBS="-llzma"
fi
dnl libgstlibav.la: include dirs
@@ -465,6 +471,8 @@ AC_SUBST(SWSCALE_CFLAGS)
AC_SUBST(SWSCALE_DEPS)
AC_SUBST(SWSCALE_LIBS)
AC_SUBST(WIN32_LIBS)
+AC_SUBST(BZ2_LIBS)
+AC_SUBST(LZMA_LIBS)
if test x$HAVE_LIBAV_UNINSTALLED = x1; then
AC_DEFINE(HAVE_LIBAV_UNINSTALLED, [], [Defined if building against uninstalled Libav source])