summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2017-10-23 19:35:31 -0700
committerTim-Philipp Müller <tim@centricular.com>2018-01-13 12:18:54 +0000
commit7a951369c7f7b3c16c4c4555e0df9f5ee693fc38 (patch)
tree61ebfefc400c97d80c0992ee3a1b288665b6ad9a /configure.ac
parenta323802c5b893f1683c702af30a82598b4ecd80b (diff)
downloadgst-libav-7a951369c7f7b3c16c4c4555e0df9f5ee693fc38.tar.gz
libav: use LIBAV_CPPFLAGS for -I include paths
Autotools automatically appends user CPPFLAGS after target CPPFLAGS. Also, it puts all CPPFLAGS before CFLAGS in final generated gcc compile command. The internal ffmpeg include paths need to come before any other external include paths to ensure we don't accidentally pickup external ffmpeg headers first (i.e. from user CPPFLAGS include paths). Thus, move the internal LIBAV include paths to LIBAV_CPPFLAGS so that they come before any user defined CPPFLAGS. This allows ffmpeg and gst-ffmpeg to coexist on users system. https://bugzilla.gnome.org/show_bug.cgi?id=789379
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1ee3c27..8944f99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -300,9 +300,10 @@ else
fi
dnl libgstlibav.la: include dirs
- LIBAV_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/libav \
- -I \$(top_builddir)/gst-libs/ext/libav \
- -Wno-deprecated-declarations"
+ LIBAV_CPPFLAGS="-I \$(top_srcdir)/gst-libs/ext/libav \
+ -I \$(top_builddir)/gst-libs/ext/libav"
+
+ LIBAV_CFLAGS="-Wno-deprecated-declarations"
LIBAV_DEPS="\$(top_builddir)/gst-libs/ext/libav/libavfilter/libavfilter.a \
\$(top_builddir)/gst-libs/ext/libav/libavformat/libavformat.a \
@@ -463,6 +464,7 @@ fi
AM_CONDITIONAL(HAVE_BZ2, test "x$HAVE_BZ2" = "xyes")
AM_CONDITIONAL(HAVE_LZMA, test "x$HAVE_LZMA" = "xyes")
+AC_SUBST(LIBAV_CPPFLAGS)
AC_SUBST(LIBAV_CFLAGS)
AC_SUBST(LIBAV_DEPS)
AC_SUBST(LIBAV_LIBS)