summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-07-16 23:47:45 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-07-17 00:57:34 +0100
commit6aa62114c5263193882441958f16c392540bdb0b (patch)
treec0220aeed047154fed78ac692dbaaafe2a080aa0 /configure.ac
parent25bf32c280282d58d2502392ed0c9634c42c79ec (diff)
downloadgst-libav-6aa62114c5263193882441958f16c392540bdb0b.tar.gz
Remove swscale plugin code
This has been disabled for 5.5 years, time to remove it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 1 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 40422af..45d9422 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,7 +256,6 @@ HAVE_LZMA="no"
HAVE_BZ2="no"
if test "x$with_system_libav" = "xyes"; then
PKG_CHECK_MODULES(LIBAV, libavfilter libavformat libavcodec >= 58 libavutil)
- PKG_CHECK_MODULES(SWSCALE, libswscale libavutil)
saved_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $LIBAV_CFLAGS"
AC_CHECK_HEADERS([avi.h])
@@ -327,23 +326,6 @@ else
$ac_pwd/gst-libs/ext/libswresample.la \
$ac_pwd/gst-libs/ext/libavutil.la"
- dnl
- SWSCALE_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/libav \
- -I \$(top_builddir)/gst-libs/ext/libav \
- -Wno-deprecated-declarations"
-
- SWSCALE_DEPS="\$(top_builddir)/gst-libs/ext/libav/libswscale/libswscale.a \
- \$(top_builddir)/gst-libs/ext/libav/libavutil/libavutil.a"
- if test "x$enable_static_plugins" = xyes; then
- dnl with static linking we can't use the .a archive directly as they would
- dnl be included in the final libgstswscale.a as a file and won't be usable.
- dnl libav*.a must be copied to the final destination too
- SWSCALE_LIBS="-lswscale -lavutil"
- else
- dnl libgstswscale.la: libs to statically link to
- SWSCALE_LIBS="$SWSCALE_DEPS"
- fi
-
LIBAV_SUBDIRS=gst-libs
AC_DEFINE(HAVE_AVI_H)
AC_DEFINE([LIBAV_SOURCE], ["local snapshot"], [Describes where the Libav libraries come from.])
@@ -359,7 +341,7 @@ else
# Enable pic and static so that we get .a files, but with PIC code.
emblibav_configure_args="$emblibav_configure_args \
--enable-static --enable-pic \
- --disable-avdevice --disable-postproc \
+ --disable-avdevice --disable-postproc --disable-swscale \
--disable-programs --disable-ffplay --disable-ffprobe --disable-ffmpeg \
--disable-encoder=flac --disable-protocols --disable-devices \
--disable-network --disable-hwaccels --disable-dxva2 --disable-vdpau \
@@ -431,11 +413,6 @@ else
if test "$can_disable" != ""; then
emblibav_configure_args="$emblibav_configure_args --disable-ffmpeg"
fi
- dnl check if libswscale needs enabling explicitly
- can_enable=`echo "$LIBAV_OPTS" | grep 'enable-swscale'`
- if test "$can_enable" != ""; then
- emblibav_configure_args="$emblibav_configure_args --enable-swscale"
- fi
# append extra configure options to emblibav_configure_args if needed
if test "x$with_libav_extra_configure" != "xno"; then
@@ -479,9 +456,6 @@ AC_SUBST(LIBAV_CFLAGS)
AC_SUBST(LIBAV_DEPS)
AC_SUBST(LIBAV_LIBS)
AC_SUBST(LIBAV_SUBDIRS)
-AC_SUBST(SWSCALE_CFLAGS)
-AC_SUBST(SWSCALE_DEPS)
-AC_SUBST(SWSCALE_LIBS)
AC_SUBST(WIN32_LIBS)
AC_SUBST(BZ2_LIBS)
AC_SUBST(LZMA_LIBS)
@@ -497,7 +471,6 @@ common/Makefile
common/m4/Makefile
ext/Makefile
ext/libav/Makefile
-ext/libswscale/Makefile
gst-libs/Makefile
gst-libs/ext/Makefile
docs/Makefile