summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-11 21:17:21 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-12 12:34:09 -0400
commit1038ae2327d0ce502bc304378afbc69602d686ed (patch)
tree75750222e398a28b9a32bd8adfea046c80efedbd /configure.ac
parentde60c46e30c9bcfe7ca6b0c3ea1f1ceabb66b4a6 (diff)
downloadgst-libav-1038ae2327d0ce502bc304378afbc69602d686ed.tar.gz
Generate .la for internal libav libraries
This should help libtool in getting the internal linking right. Effectively, libtool can sometime get the link order wrong when presented with a mix of .la and -l arguments. These .la file are also required by the android build system and were previously created by cerbero.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 7cdf8e2..86174f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -314,17 +314,17 @@ else
-I \$(top_builddir)/gst-libs/ext/libav \
-Wno-deprecated-declarations"
- LIBAV_DEPS="\$(top_builddir)/gst-libs/ext/libav/libavformat/libavformat.a \
+ LIBAV_DEPS="\$(top_builddir)/gst-libs/ext/libav/libavfilter/libavfilter.a \
+ \$(top_builddir)/gst-libs/ext/libav/libavformat/libavformat.a \
\$(top_builddir)/gst-libs/ext/libav/libavcodec/libavcodec.a \
- \$(top_builddir)/gst-libs/ext/libav/libavfilter/libavfilter.a \
\$(top_builddir)/gst-libs/ext/libav/libswresample/libswresample.a \
\$(top_builddir)/gst-libs/ext/libav/libavutil/libavutil.a"
- LIBAV_LIBS="-L\$(top_builddir)/gst-libs/ext/libav/libavformat -lavformat \
- -L\$(top_builddir)/gst-libs/ext/libav/libavcodec -lavcodec \
- -L\$(top_builddir)/gst-libs/ext/libav/libswresample -lswresample \
- -L\$(top_builddir)/gst-libs/ext/libav/libavutil -lavutil \
- -L\$(top_builddir)/gst-libs/ext/libav/libavfilter -lavfilter"
+ LIBAV_LIBS="$ac_pwd/gst-libs/ext/libavfilter.la \
+ $ac_pwd/gst-libs/ext/libavformat.la \
+ $ac_pwd/gst-libs/ext/libavcodec.la \
+ $ac_pwd/gst-libs/ext/libswresample.la \
+ $ac_pwd/gst-libs/ext/libavutil.la"
dnl
SWSCALE_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/libav \