summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-10 21:20:05 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-05-11 10:08:14 -0400
commit0b48f0e3fdc5c5fe8530345b165e7cd0aecb2b5b (patch)
tree79c0b29a85bd6330c3bb8bc677a62f4f087bba9d /configure.ac
parent46691bd0ec98723914df6678aad39ccb3d1ffd8f (diff)
downloadgst-libav-0b48f0e3fdc5c5fe8530345b165e7cd0aecb2b5b.tar.gz
Use a portable method to link against internal FFMPEG
In the last iteration, we kept the original method to link the shared plugin and edited the .a and .la files so satisfy what cerbero needed. Unfortunately, that required adding .a file into the archive which is not allowed with iOS ar command for universal builds. This patch uses standard method to link a static library. One of the benefit is that it removes some libtool warning about portability. For the static case, we implement an install hook that installs FFMPEG internal .a files in the plugin directory (so it does not get confused with a possible system FFMPEG. This makes the static plugin usable without depending on cerbero recipe.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 113376b..7cdf8e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -319,15 +319,12 @@ else
\$(top_builddir)/gst-libs/ext/libav/libavfilter/libavfilter.a \
\$(top_builddir)/gst-libs/ext/libav/libswresample/libswresample.a \
\$(top_builddir)/gst-libs/ext/libav/libavutil/libavutil.a"
- if test "x$enable_static_plugins" = xyes; then
- dnl with static linking we can't use the .a archive directly as they would
- dnl be included in the final libgstlibav.a as a file and won't be usable.
- dnl libav*.a must be copied to the final destination too
- LIBAV_LIBS="-lavformat -lavcodec -lswresample -lavutil -lavfilter"
- else
- dnl libgstlibav.la: libs to statically link to
- LIBAV_LIBS="$LIBAV_DEPS"
- fi
+
+ LIBAV_LIBS="-L\$(top_builddir)/gst-libs/ext/libav/libavformat -lavformat \
+ -L\$(top_builddir)/gst-libs/ext/libav/libavcodec -lavcodec \
+ -L\$(top_builddir)/gst-libs/ext/libav/libswresample -lswresample \
+ -L\$(top_builddir)/gst-libs/ext/libav/libavutil -lavutil \
+ -L\$(top_builddir)/gst-libs/ext/libav/libavfilter -lavfilter"
dnl
SWSCALE_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/libav \