summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2023-04-08 18:16:46 -0700
committerJim Meyering <meyering@meta.com>2023-04-09 22:22:42 -0700
commit88b2d37c0a975b736841f66c1b64401bb4d329f3 (patch)
tree35214a8e534ee64e339c0942d8b8f0a08a0e3ee7 /tests/Makefile.am
parent19d2275fd1195f00e4ffc90a03b388c55d858681 (diff)
downloadgrep-88b2d37c0a975b736841f66c1b64401bb4d329f3.tar.gz
grep: --version: print pcre version info
PCRE is integral to the functioning of grep's -P option, so it is in our interest to make it easy to see which version of PCRE grep uses. * src/grep.c [HAVE_LIBPCRE]: Include <pcre2.h>. [HAVE_LIBPCRE] (main): Print pcre version info. * tests/version-pcre: New test for this. * tests/Makefile.am (TESTS): Add the file name. * NEWS (Changes in behavior): Mention it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c9376b19..0ef96d44 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -178,6 +178,7 @@ TESTS = \
unibyte-bracket-expr \
unibyte-negated-circumflex \
utf8-bracket \
+ version-pcre \
warn-char-classes \
word-delim-multibyte \
word-multi-file \
@@ -254,6 +255,7 @@ TESTS_ENVIRONMENT = \
srcdir='$(srcdir)' \
top_srcdir='$(top_srcdir)' \
CC='$(CC)' \
+ CONFIG_HEADER='$(abs_top_builddir)/$(CONFIG_INCLUDE)' \
GREP_TEST_NAME=`echo $$tst|sed 's,^\./,,;s,/,-,g'` \
MAKE=$(MAKE) \
MALLOC_PERTURB_=$(MALLOC_PERTURB_) \